2000 Windstar engine or tranny mount - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-20-05, 05:01 PM
Richard Cox
Guest
 
Posts: n/a
2000 Windstar engine or tranny mount

I have a 2000 Windstar that seems to be having some issues. When you
take it out of park the transmission clunks, when you hit the gas, the
front end gets very loose and when you hit the brakes, the front end
dives and you can hear something rubbing on the tire or something else.
I think this is either the engine mount or the tranny mount, but not
sure. How hard is it to replace either of these? Any input would be
helpful!. Thanks in advance.
Rich
 
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-20-05, 05:01 PM
fomococo@hotmail.com
Guest
 
Posts: n/a
Re: 2000 Windstar engine or tranny mount

On Mon, 20 Jun 2005 15:12:51 -0700, Richard Cox
<rkcoxcpf@starband.net> wrote:

>I have a 2000 Windstar that seems to be having some issues. When you
>take it out of park the transmission clunks, when you hit the gas, the
>front end gets very loose and when you hit the brakes, the front end
>dives and you can hear something rubbing on the tire or something else.
>I think this is either the engine mount or the tranny mount, but not
>sure. How hard is it to replace either of these? Any input would be
>helpful!. Thanks in advance.
>Rich


replace motor mounts
they are infact oil filled
look for the leaky one
h
u
r
c
a
s
t

 
post #3 of 3 (permalink) Old 06-21-05, 11:01 AM
Richard Cox
Guest
 
Posts: n/a
Re: 2000 Windstar engine or tranny mount



fomococo@hotmail.com wrote:
> On Mon, 20 Jun 2005 15:12:51 -0700, Richard Cox
> <rkcoxcpf@starband.net> wrote:
>
>
>>I have a 2000 Windstar that seems to be having some issues. When you
>>take it out of park the transmission clunks, when you hit the gas, the
>>front end gets very loose and when you hit the brakes, the front end
>>dives and you can hear something rubbing on the tire or something else.
>>I think this is either the engine mount or the tranny mount, but not
>>sure. How hard is it to replace either of these? Any input would be
>>helpful!. Thanks in advance.
>>Rich

>
>
> replace motor mounts
> they are infact oil filled
> look for the leaky one


Thanks hurcast, but how hard are these to replace. Looks like Napa has
them in stock for about $30.50.

Rich
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome