2000 Windstar engine or tranny mount - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-20-2005, 16:01   #1 (permalink)
Richard Cox
Guest
 
Posts: n/a
2000 Windstar engine or tranny mount

I have a 2000 Windstar that seems to be having some issues. When you
take it out of park the transmission clunks, when you hit the gas, the
front end gets very loose and when you hit the brakes, the front end
dives and you can hear something rubbing on the tire or something else.
I think this is either the engine mount or the tranny mount, but not
sure. How hard is it to replace either of these? Any input would be
helpful!. Thanks in advance.
Rich
  Reply With Quote
Sponsored Links
Advertisement
 
Old 06-20-2005, 16:01   #2 (permalink)
fomococo@hotmail.com
Guest
 
Posts: n/a
Re: 2000 Windstar engine or tranny mount

On Mon, 20 Jun 2005 15:12:51 -0700, Richard Cox
<rkcoxcpf@starband.net> wrote:

>I have a 2000 Windstar that seems to be having some issues. When you
>take it out of park the transmission clunks, when you hit the gas, the
>front end gets very loose and when you hit the brakes, the front end
>dives and you can hear something rubbing on the tire or something else.
>I think this is either the engine mount or the tranny mount, but not
>sure. How hard is it to replace either of these? Any input would be
>helpful!. Thanks in advance.
>Rich


replace motor mounts
they are infact oil filled
look for the leaky one
h
u
r
c
a
s
t

  Reply With Quote
Old 06-21-2005, 10:01   #3 (permalink)
Richard Cox
Guest
 
Posts: n/a
Re: 2000 Windstar engine or tranny mount



fomococo@hotmail.com wrote:
> On Mon, 20 Jun 2005 15:12:51 -0700, Richard Cox
> <rkcoxcpf@starband.net> wrote:
>
>
>>I have a 2000 Windstar that seems to be having some issues. When you
>>take it out of park the transmission clunks, when you hit the gas, the
>>front end gets very loose and when you hit the brakes, the front end
>>dives and you can hear something rubbing on the tire or something else.
>>I think this is either the engine mount or the tranny mount, but not
>>sure. How hard is it to replace either of these? Any input would be
>>helpful!. Thanks in advance.
>>Rich

>
>
> replace motor mounts
> they are infact oil filled
> look for the leaky one


Thanks hurcast, but how hard are these to replace. Looks like Napa has
them in stock for about $30.50.

Rich
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.