95 E250 Cargo 4.9L I6 questions - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-22-05, 10:01 AM
Ford Warrior
Posts: n/a
95 E250 Cargo 4.9L I6 questions


I just purchased a 3/4 ton 1995 E-250 Cargo van with I6 4.9L engine and
3-speed (I was told) auto transmission. A few questions/problems:

What is the transmission model for this vehicle?

Van drives smooth until I get on the highway and approach 55-65 mph. Once I
get into this speed (I'm thinking) it's in the upper range of 2nd gear. A
loud low frequency hum then starts which gets a bit louder until I
accelerate around over 65mph and then (again I'm just thinking) it shifts
into 3rd gear and goes back to sounding smooth and normal. The vehicle
doesn't seem to lag or slip at all.. it's just this loud deep almost
rumbling sound... definitely not shaking or anything involving movement of
the vehicle. Could this be a delay in shifting leading to high rpms at the
upper end of 2nd gear? The vehicle has been sitting in a car lot for a long
period of time and I was thinking perhaps may just need tranny filter/fluid
change. Then again it could be something else in the drivetrain, I'm no
expert. Any recommendations as to my course of action here? Also any
recommendations for brand of fluid to use? Is there an easy way for me to
perform the filter/fluid change without the old fluid spilling out in all
directions when i drop the pan?

This may or may not be normal for a large cargo van but it seems to me there
is a large amount of inertia when accelerating this vehicle almost as
though something is dragging.. even when coasting downhills the van is
decelerating and slowing down. New front brake pads were just installed @
the shop. Could be something in the drivetrain though I wouldn't know what
areas to look at. Again.. any recommendations for things to check?

Please keep in mind I'm barely an amateur when it comes to auto repair..
I've worked on a '93 Taurus 3.0gl and an '86 toyota tercel awhile back.

Please do not reply via email, instead reply in this newsgroup to minimize
my spam problems. Thanks for your help!
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome