96 merc sable transmission quirk - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-26-05, 10:01 AM
Don
Guest
 
Posts: n/a
96 merc sable transmission quirk

My sable has 60,000 miles on it and on light acceleration at highway
speeds it has what seems to be a stutter. Also it has a hard downshift
when comming to a stop. The trans fluid is of a very light brown color
insted of pink. This has happened over the past 2 months or so. I'm
changing fluid today. Does anyone reccomend a brand of additive that
might resolve this problem? Thanks



 
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-26-05, 07:01 PM
nospam4me@nospam.com
Guest
 
Posts: n/a
Re: 96 merc sable transmission quirk

Drop pan and clean and fil land then do a flush using the most recent
version of Mercon for your car . I have have good luck with Lubegard
products ( www.lubgard.com ) . Cross your fingers . Those transaxles
are bad news IMO .

On 26 Apr 2005 09:23:23 -0700, "Don" <fortyone_coupe@yahoo.com> wrote:

>My sable has 60,000 miles on it and on light acceleration at highway
>speeds it has what seems to be a stutter. Also it has a hard downshift
>when comming to a stop. The trans fluid is of a very light brown color
>insted of pink. This has happened over the past 2 months or so. I'm
>changing fluid today. Does anyone reccomend a brand of additive that
>might resolve this problem? Thanks
>


 
post #3 of 3 (permalink) Old 04-28-05, 08:01 AM
Don
Guest
 
Posts: n/a
Re: 96 merc sable transmission quirk

Thanks for the advice changed oil, filter added Lubegard Platinum
shifts smooth as silk so far.

 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome