problem with 2000 crown victoria! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-15-05, 04:01 AM
Posts: n/a
problem with 2000 crown victoria!

ok my engine does burn gas and I think its the piston rings but once in a
while I hear this DING sound and a plume of smoke comes out of the tail
pipe and the engine starts to have idling problems as if it wants to
and sometimes it does. and this has been happening more often lately, was
wondering what could cause this? are the piston rings getting so bad that
the oil is getting way upthere where the spark plugs are and shutting
off? or is the the knocking/pre ignition everybody talks about(scanned
computer no codes regarding pre ignition) now I know I have pretty bad
catalytic converters (still passed smog 3months ago) and a bad evap
but I really dont think these problems could be the cause of this. and
how hard is it exactly to change piston rings on these it
possible to do this without taking the engine out of the car. any help
appreciated. thanks

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups >
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome