Re: 99 Mecury Cougar question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-08-05, 10:02 PM
Posts: n/a
Re: 99 Mecury Cougar question

"Jerevin" wrote:
> recently i got a 99 cougar (used) and its been running fine
> for the last week but today i went to start it and nothing.
> the key starts all the basic electrical functions like power
> seats and clock. but other then that the power locks dont
> respond and the actual egnition wont kick over. it wont start
> no matter drive or park or anything and on top of that i dont
> have the owners manual (because it being a used car) and
> theres a check engine dashboard light on the first light from
> the left but i cant tell what excatly the problem is... is it
> possible its just the battery?..or am i looking at shelling
> out more money..? any insight would be useful..

alright..well just incase anyone saught the problem i figured it
out..the negative connector to the batter was torn so replacement is
all i need...
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups >
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome