windstar transmission - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-12-2006, 19:01   #1 (permalink)
rpms0605@yahoo.com
Guest
 
Posts: n/a
windstar transmission

I have a 1996 Windstar with 115,000 miles. Replaced the 3.8 at 75,000
miles. In the last month the auto tranny has twice stuck in second gear.
This is an intermittent problem - I drive it every day for about 25
miles and only twice has this happened, normally is shifts fine. I had
the coolant flushed about 40,000 miles ago. Does this sond like an
electrical/sensor problem or something much worse? Also, on the gear
lever the auto overdrive button id very dimly lit. Is this normal?
  Reply With Quote
Sponsored Links
Advertisement
 
Old 01-13-2006, 07:01   #2 (permalink)
Ted
Guest
 
Posts: n/a
Re: windstar transmission

There are two electrical connectors at the top of the trans; unplug them and
look for signs of brake fluid or antifreeze intrusion; clean the connectors
with Brakekleen or similar electrical cleaner. If the problem persists,
replace the transmission range sensor.
<rpms0605@yahoo.com> wrote in message
news:20060112211725611-0500@news1.news.adelphia.net...
>I have a 1996 Windstar with 115,000 miles. Replaced the 3.8 at 75,000
> miles. In the last month the auto tranny has twice stuck in second gear.
> This is an intermittent problem - I drive it every day for about 25
> miles and only twice has this happened, normally is shifts fine. I had
> the coolant flushed about 40,000 miles ago. Does this sond like an
> electrical/sensor problem or something much worse? Also, on the gear
> lever the auto overdrive button id very dimly lit. Is this normal?



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:01.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.