ZTS instrument panel makes a ticking sounds - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-27-05, 04:01 PM
Andie144 via CarKB.com
Guest
 
Posts: n/a
ZTS instrument panel makes a ticking sounds

Hi,
Once my Focus hit 60,000 miles I started to hear a ticking sound coming
from the instrument panel
when I applied the brakes. I took it to the dealership but they don't know
what's wrong because the car never seems to act up when anyone else is
driving it! Please, if anyone else had this happen to them. What did you do?


Thanks,
Andie
 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-30-05, 01:01 AM
BradandBrooks
Guest
 
Posts: n/a
Re: ZTS instrument panel makes a ticking sounds

Ticking sound from the cluster? Speedo cable. Dunno what else it could be.

Brad

"Andie144 via CarKB.com" <u14350@uwe> wrote in message
news:5502384cd9dc1@uwe...
> Hi,
> Once my Focus hit 60,000 miles I started to hear a ticking sound coming
> from the instrument panel
> when I applied the brakes. I took it to the dealership but they don't
> know
> what's wrong because the car never seems to act up when anyone else is
> driving it! Please, if anyone else had this happen to them. What did you
> do?
>
>
> Thanks,
> Andie



 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.autos.ford
Gear in this thread - Powered by O'Reilly Auto Parts

« Fuel Problem | test »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome