1993 4x4 Explorer EEC Fuse continues to blow and engine quits. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-17-05, 12:02 AM
s388ra
Guest
 
Posts: n/a
1993 4x4 Explorer EEC Fuse continues to blow and engine quits.

I have researched the Hayes book and cannot find what this EEC fuse powers.
Since the engine will crank but not run when the fuse is blown, I suspect
that the fuel pump and the electronic ignation may be part of it. But
since the engine will run for about 30 sec. to a minute before it blows
the fuse, I do not think it is a fuel pump problem. So this leaves the
electronic ignition and what ever else the fuse powers. I at a loss on
this one. Can some one give me a Idea on what to do next?
Thanks



 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
VZ HSV pics & info FPRXR-6 The Pub 79 10-10-04 03:04 PM
MAF Modification *i2ayman* Windsor Tech 8 05-11-04 08:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome