2000 EG Oil Pressure sending unit - Stuck? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-04-05, 11:01 AM
Bill
Guest
 
Posts: n/a
2000 EG Oil Pressure sending unit - Stuck?

The oil pressure gauge (I know it really is an idiot light with a needle),
appears to be stuck at the bottom until the engine warms a bit, then it
"pops" to the proper position. Does this behavior indicate a bad sending
unit?


 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-05-05, 01:01 PM
MACE
Guest
 
Posts: n/a
Re: 2000 EG Oil Pressure sending unit - Stuck?


Bill Wrote:
> The oil pressure gauge (I know it really is an idiot light with a
> needle),
> appears to be stuck at the bottom until the engine warms a bit, then
> it
> "pops" to the proper position. Does this behavior indicate a bad
> sending
> unit?


sure does. unless your engine is clattering and making unusual noises.
my oil pressure switch went bad too. common problem


--
MACE
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome