2001 Expedition Front Timing Chain Noise - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-30-05, 10:01 AM
Posts: n/a
2001 Expedition Front Timing Chain Noise

Could really use some help from the group with this one. 5.4L engine
with P&I heads, 110K miles but well maintained every 3000 with
synthetic oil. Loud rattle from the front of the engine. Two Ford
dealerships are suggesting front timing chain(s?), however both suggest
engine swap. It seems both shops have limited experience doing the
chain repair. Said this problem is pretty rare.

Has anyone else seen this problem with this engine? Any suggestions?
The repair is $1700 and the swap is $5700. No guarantee on the repair.
Its my daughter's truck and in this shape I'm afraid she owes more
than it might be worth.

Thanks in advance. - JimC

Sponsored Links
post #2 of 2 (permalink) Old 08-24-05, 06:01 AM
Posts: n/a
Re: 2001 Expedition Front Timing Chain Noise

Dear JimC
Your request has given me information thatI did not have. I don't know how
rare this problem is. I have a 1998 Expedition with the same problem.

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome