94 explorer hesitation when accelerating - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-19-05, 09:01 AM
kylo67
Guest
 
Posts: n/a
94 explorer hesitation when accelerating

I have a 94 explorer and it hesitates when accelerating, especially right
after first starting it. I changed plugs, plug wires, fuel pump, air
filter, oxygen sensor, and fuel filter. Any other suggestions.

Thanks


 
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-19-05, 11:01 AM
johanb
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

C.E.L on ?????????

if not, it's usually dirt related.
clean your iac and maf sensors


"kylo67" <dqnascar@yahoo.com> wrote in message
news:ef0a473b2529417d8801270ea44839c3@localhost.talkaboutautos.com...
> I have a 94 explorer and it hesitates when accelerating, especially right
> after first starting it. I changed plugs, plug wires, fuel pump, air
> filter, oxygen sensor, and fuel filter. Any other suggestions.
>
> Thanks
>
>
>



 
post #3 of 7 (permalink) Old 10-20-05, 05:01 PM
kylo67
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

Johanb:

thanks for the info
I,ll give it a try

thanks

 
post #4 of 7 (permalink) Old 10-21-05, 09:01 PM
kylo67
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

JOHANB

Thanks again. I changed the MAF(mass air flow) sensor and it is working
correctly again.

Great information!!!!!!



 
post #5 of 7 (permalink) Old 10-22-05, 01:01 AM
johanb
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

No problem, thanks for the follow-up


"kylo67" <dqnascar@yahoo.com> wrote in message
news:6b6d46e3854589f1d182be3d25046dfe@localhost.talkaboutautos.com...
> JOHANB
>
> Thanks again. I changed the MAF(mass air flow) sensor and it is working
> correctly again.
>
> Great information!!!!!!
>
>
>



 
post #6 of 7 (permalink) Old 10-24-05, 04:01 PM
Ulysses
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

I love it when folks post their results, especially when it solved the
problem!

"johanb" <ollieb1oREMOVE@THIScs.com> wrote in message
news:qcl6f.84$BC1.12557@news.uswest.net...
> No problem, thanks for the follow-up
>
>
> "kylo67" <dqnascar@yahoo.com> wrote in message
> news:6b6d46e3854589f1d182be3d25046dfe@localhost.talkaboutautos.com...
> > JOHANB
> >
> > Thanks again. I changed the MAF(mass air flow) sensor and it is working
> > correctly again.
> >
> > Great information!!!!!!
> >
> >
> >

>
>



 
post #7 of 7 (permalink) Old 10-25-05, 03:02 AM
johanb
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

I know, we try to help them saving money on high repair cost and most of
them don't even bother to reply.....

This is 1 of the exceptions



"Ulysses" <therealulysses@yahoo.com> wrote in message
news:11lqkn5dfr5jkf2@corp.supernews.com...
> I love it when folks post their results, especially when it solved the
> problem!
>
> "johanb" <ollieb1oREMOVE@THIScs.com> wrote in message
> news:qcl6f.84$BC1.12557@news.uswest.net...
> > No problem, thanks for the follow-up
> >
> >
> > "kylo67" <dqnascar@yahoo.com> wrote in message
> > news:6b6d46e3854589f1d182be3d25046dfe@localhost.talkaboutautos.com...
> > > JOHANB
> > >
> > > Thanks again. I changed the MAF(mass air flow) sensor and it is

working
> > > correctly again.
> > >
> > > Great information!!!!!!
> > >
> > >
> > >

> >
> >

>
>
>



 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome