94 explorer hesitation when accelerating - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-19-2005, 08:01   #1 (permalink)
kylo67
Guest
 
Posts: n/a
94 explorer hesitation when accelerating

I have a 94 explorer and it hesitates when accelerating, especially right
after first starting it. I changed plugs, plug wires, fuel pump, air
filter, oxygen sensor, and fuel filter. Any other suggestions.

Thanks


  Reply With Quote
Sponsored Links
Advertisement
 
Old 10-19-2005, 10:01   #2 (permalink)
johanb
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

C.E.L on ?????????

if not, it's usually dirt related.
clean your iac and maf sensors


"kylo67" <dqnascar@yahoo.com> wrote in message
news:ef0a473b2529417d8801270ea44839c3@localhost.talkaboutautos.com...
> I have a 94 explorer and it hesitates when accelerating, especially right
> after first starting it. I changed plugs, plug wires, fuel pump, air
> filter, oxygen sensor, and fuel filter. Any other suggestions.
>
> Thanks
>
>
>



  Reply With Quote
Old 10-20-2005, 16:01   #3 (permalink)
kylo67
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

Johanb:

thanks for the info
I,ll give it a try

thanks

  Reply With Quote
Old 10-21-2005, 20:01   #4 (permalink)
kylo67
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

JOHANB

Thanks again. I changed the MAF(mass air flow) sensor and it is working
correctly again.

Great information!!!!!!



  Reply With Quote
Old 10-22-2005, 00:01   #5 (permalink)
johanb
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

No problem, thanks for the follow-up


"kylo67" <dqnascar@yahoo.com> wrote in message
news:6b6d46e3854589f1d182be3d25046dfe@localhost.talkaboutautos.com...
> JOHANB
>
> Thanks again. I changed the MAF(mass air flow) sensor and it is working
> correctly again.
>
> Great information!!!!!!
>
>
>



  Reply With Quote
Old 10-24-2005, 15:01   #6 (permalink)
Ulysses
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

I love it when folks post their results, especially when it solved the
problem!

"johanb" <ollieb1oREMOVE@THIScs.com> wrote in message
news:qcl6f.84$BC1.12557@news.uswest.net...
> No problem, thanks for the follow-up
>
>
> "kylo67" <dqnascar@yahoo.com> wrote in message
> news:6b6d46e3854589f1d182be3d25046dfe@localhost.talkaboutautos.com...
> > JOHANB
> >
> > Thanks again. I changed the MAF(mass air flow) sensor and it is working
> > correctly again.
> >
> > Great information!!!!!!
> >
> >
> >

>
>



  Reply With Quote
Old 10-25-2005, 02:02   #7 (permalink)
johanb
Guest
 
Posts: n/a
Re: 94 explorer hesitation when accelerating

I know, we try to help them saving money on high repair cost and most of
them don't even bother to reply.....

This is 1 of the exceptions



"Ulysses" <therealulysses@yahoo.com> wrote in message
news:11lqkn5dfr5jkf2@corp.supernews.com...
> I love it when folks post their results, especially when it solved the
> problem!
>
> "johanb" <ollieb1oREMOVE@THIScs.com> wrote in message
> news:qcl6f.84$BC1.12557@news.uswest.net...
> > No problem, thanks for the follow-up
> >
> >
> > "kylo67" <dqnascar@yahoo.com> wrote in message
> > news:6b6d46e3854589f1d182be3d25046dfe@localhost.talkaboutautos.com...
> > > JOHANB
> > >
> > > Thanks again. I changed the MAF(mass air flow) sensor and it is

working
> > > correctly again.
> > >
> > > Great information!!!!!!
> > >
> > >
> > >

> >
> >

>
>
>



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.