97 cruise control mount came off wheel... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-07-05, 09:01 PM
Posts: n/a
97 cruise control mount came off wheel...

Pushed the cruise button yesterday, and the whole steering wheel-mounted
"pod" moved...still seems partially hooked to the wheel on the
bottom...anyone know how to check/fix the mounting of this? without setting
off the airbag <G>? My manual is no help in this. TIA

97 Explorer
00 Ranger 4X4

Sponsored Links
post #2 of 2 (permalink) Old 07-08-05, 10:01 AM
Posts: n/a
Re: 97 cruise control mount came off wheel...

disconnect the battery & wait 2 - 30 minutes (depending on who you
talk to; i disconnect & burn one, then resume work).

ground yourself. remove 1 bolt on either side of the steering wheel
covered by caps, i think they may be 10mm if i remember. the airbag
pad will sort of flop forward, so be ready.

disconnect the airbag. careful! if you are statically charged, i hear
it can go poof. YMMV.

now you can see the where the cruise control buttons are screwed to the
steering wheel. if one of the screws has fallen, just put it back. if
it is lost or the button is broken at the top, you will either need a
new screw, a new button, or some form of re-engineering.

i think those are the right steps, but if not, you'll be able to tell
once you get the pad off. installation is reverse of removal. don't
forget to be careful with that airbag, if it splodes it's on u! good

oh yeah, don't retighten the 10mm bolts too much or your horn will be a
B* to honk.

96 XLT 4.0L 4DR 4WD

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome