'99 Ford Explorer turn signals/hazzards - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-01-05, 10:01 AM
clong1216
Guest
 
Posts: n/a
'99 Ford Explorer turn signals/hazzards

My turn signals and hazzards don't work. There's no fast, loud clicking
sound so I don't think one of the bulbs is burned out. Any ideas?



 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-01-05, 08:01 PM
johanb
Guest
 
Posts: n/a
Re: '99 Ford Explorer turn signals/hazzards

dirty hazard switch, push it on/off a couple of times fast


"clong1216" <clong1216@yahoo.com> wrote in message
news:ca53c7a3226386aca96214a2f3585709@localhost.talkaboutautos.com...
> My turn signals and hazzards don't work. There's no fast, loud clicking
> sound so I don't think one of the bulbs is burned out. Any ideas?
>
>



 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome