99 XLT brake lights not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-17-2005, 07:01   #1 (permalink)
jriechert@gmail.com
Guest
 
Posts: n/a
99 XLT brake lights not working

None of the 3 brake lights are working. I've narrowed it down to either
the brake light switch on the pedal or the wiring at that connector. If
I wiggle the wiring the lights will start working for awhile. I can
also pivot the switch back and forth slightly on the pivot pin and get
the lights to come on. AFAICT the wiring and connector are OK. So, is
there a good chance that the switch is going bad and should be replaced?

  Reply With Quote
Sponsored Links
Advertisement
 
Old 11-17-2005, 20:01   #2 (permalink)
Jerry
Guest
 
Posts: n/a
Re: 99 XLT brake lights not working

jriechert@gmail.com wrote:
> None of the 3 brake lights are working. I've narrowed it down to either
> the brake light switch on the pedal or the wiring at that connector. If
> I wiggle the wiring the lights will start working for awhile. I can
> also pivot the switch back and forth slightly on the pivot pin and get
> the lights to come on. AFAICT the wiring and connector are OK. So, is
> there a good chance that the switch is going bad and should be replaced?
>


I went ahead and bought a new switch. Lights work fine now.
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:03.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.