O/D light flashing -- fault code 645 -- HELP !!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-24-05, 12:01 PM
Paul
Guest
 
Posts: n/a
O/D light flashing -- fault code 645 -- HELP !!!

Hi. I'm looking for some insight into a tranny problem I am having. I
have a 1995 Explorer XLT 4WD Automatic V6. Had tranny "rebuilt" last
week after slipping in several gears and O/D Off light flashing. On the
drive home from shop, car is running great for 20 minutes or so, then
O/D Off light starts flashing, first gear turns to mush, and I get two
noticeable "thunks" during downshift, one at about 15 mph, then again
at 10mph. At home, using my hand held code reader, I get fault code 645
"Incorrect gear ratio-first gear". I reset EEC by disconnecting battery
and the car ran perfect for maybe 10-15 minutes, then the same symptoms
reappear. I do not know how much, if any, of the electronics was
replaced or repaired by the "mechanic", so I'm thinking that the
"repair" was incomplete, and I have lingering electronic issues that
are manifesting as mechanic problems. There are tons of posts related
to this, and I have read many, and will continue to read more. I have
heard mention of solenoids getting stuck, but don't know if this
applies to my situation. Any advise would be greatly appreciated. TIA.
- Paul



 
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-24-05, 12:01 PM
Paul
Guest
 
Posts: n/a
Re: O/D light flashing -- fault code 645 -- HELP !!!

Oh yeah, forgot to mention that IF I put the tranny in the "1" or "2"
position, rather than the "D" position, first gear comes back, and the
two "thinks" disappear. The O/D Off light continues to blink, however.
Weird!?

 
post #3 of 3 (permalink) Old 11-24-05, 03:01 PM
Paul
Guest
 
Posts: n/a
Re: O/D light flashing -- fault code 645 -- HELP !!!

good grief...make that two "thunks"...

 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome