Oil Filter Relo kit / engine RPM's - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-28-05, 06:01 AM
Posts: n/a
Oil Filter Relo kit / engine RPM's

Installed oil filter relocation kit, and didnt notice at first, as I
have a jumpy tach...but the RPM's are lower. Engine noticebly running
cooler per the temp gage also / maybe 20 deg cooler. In Idle, when hot,
down 100rpm, and pretty much down 100-200rpm through most speeds. Not
sure if this is a good or bad thing. Real oil press gauge in normal
ranges, avg 50 psi.., OEM oil switch gage in the middle, engine sounds
good, no engine lights on. Is the engine just running easier, or is is
struggling? used 5w30 Mobil syn, truck has 78k. Air temp 50..

Very concerned; should I be worried?

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.explorer
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome