'93 Mustang LX, radiator fan problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-24-05, 02:02 PM
JRnNC
Guest
 
Posts: n/a
'93 Mustang LX, radiator fan problem

My son's '93 has twice now run down the battery, cause is radiator fan
continues to run after switching off the engine. According to the FORD
CD I have, it is controlled by the "Constant Control Relay Module",
which evidently controls other things too.
Any of you guys seen a similar problem or have experience trouble
shooting this problem?
Thanks, JRnNC



 
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-24-05, 07:01 PM
Mike R
Guest
 
Posts: n/a
Re: '93 Mustang LX, radiator fan problem

In article <1122237628.876568.13920@o13g2000cwo.googlegroups.com>, "JRnNC"
<chowrunner@aol.com> wrote:

> My son's '93 has twice now run down the battery, cause is radiator fan
> continues to run after switching off the engine. According to the FORD
> CD I have, it is controlled by the "Constant Control Relay Module",
> which evidently controls other things too.
> Any of you guys seen a similar problem or have experience trouble
> shooting this problem?
> Thanks, JRnNC


The electric cooling fan on the 93 2.3L is designed to only operate with
the ignition switch in the run position. I would therefore put the CCRM
high on the suspect list. One of the two solid state driver relays inside
the module may be stuck in the closed position...HTH

--
Mike
93 Cobra
 
post #3 of 3 (permalink) Old 07-25-05, 06:01 AM
JR
Guest
 
Posts: n/a
Re: '93 Mustang LX, radiator fan problem

Thanks Mike! Guess we'll go after that CCRM.
JRnNC

Mike R wrote:

> In article <1122237628.876568.13920@o13g2000cwo.googlegroups.com>, "JRnNC"
> <chowrunner@aol.com> wrote:
>
> > My son's '93 has twice now run down the battery, cause is radiator fan
> > continues to run after switching off the engine. According to the FORD
> > CD I have, it is controlled by the "Constant Control Relay Module",
> > which evidently controls other things too.
> > Any of you guys seen a similar problem or have experience trouble
> > shooting this problem?
> > Thanks, JRnNC

>
> The electric cooling fan on the 93 2.3L is designed to only operate with
> the ignition switch in the run position. I would therefore put the CCRM
> high on the suspect list. One of the two solid state driver relays inside
> the module may be stuck in the closed position...HTH
>
> --
> Mike
> 93 Cobra


 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.mustang


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome