Throttle hangs--90 LX 5.0 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-23-05, 06:01 PM
Dave Combs
Guest
 
Posts: n/a
Throttle hangs--90 LX 5.0

I recently had the injectors replaced on my 5.0. Ever since then, when I
let off the throttle coming to a stop (5-speed) the engine "hangs" at 2,000
rpm instead of dropping to 700 rpm. Do you think they may have screwed up
the throttle linkage or is there another likely suspect.

Thanks




 
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-23-05, 07:01 PM
Joe
Guest
 
Posts: n/a
Re: Throttle hangs--90 LX 5.0

"Dave Combs" <jdcombs@socal.rr.com> wrote in
news:SoU6f.2813$QM5.2549@tornado.socal.rr.com:

> I recently had the injectors replaced on my 5.0. Ever since then,
> when I let off the throttle coming to a stop (5-speed) the engine
> "hangs" at 2,000 rpm instead of dropping to 700 rpm. Do you think
> they may have screwed up the throttle linkage or is there another
> likely suspect.
>
> Thanks


Maybe some kind of vacuum issue?
 
post #3 of 7 (permalink) Old 10-23-05, 10:01 PM
Dave Combs
Guest
 
Posts: n/a
Re: Throttle hangs--90 LX 5.0

I forgot to say that it only happens intermittently

Dave

"Joe" <avoidingspam@nospam.com> wrote in message news:qgW6f.2758.
$NJ.1630@bignews7.bellsouth.net...
> "Dave Combs" <jdcombs@socal.rr.com> wrote in
> news:SoU6f.2813$QM5.2549@tornado.socal.rr.com:
>
> > I recently had the injectors replaced on my 5.0. Ever since then,
> > when I let off the throttle coming to a stop (5-speed) the engine
> > "hangs" at 2,000 rpm instead of dropping to 700 rpm. Do you think
> > they may have screwed up the throttle linkage or is there another
> > likely suspect.
> >
> > Thanks

>
> Maybe some kind of vacuum issue?



 
post #4 of 7 (permalink) Old 10-23-05, 10:01 PM
cprice@here.com
Guest
 
Posts: n/a
Re: Throttle hangs--90 LX 5.0

Dave Combs wrote:

> I recently had the injectors replaced on my 5.0. Ever since then, when I
> let off the throttle coming to a stop (5-speed) the engine "hangs" at 2,000
> rpm instead of dropping to 700 rpm. Do you think they may have screwed up
> the throttle linkage or is there another likely suspect.
>
> Thanks
>
>


Something in my memory says this has something to do with the 'salt and
pepper' shaker eletrical connectors. I think they immediately behind the
upper intake on a 5.0.

Try this link.

http://fordfuelinjection.com/index.php?p=85

You might also have a vaccum leak. You might need to clear your
pcm/computer by disconnecting the battery for 30 mins and then starting
it to allow the pcm to setup its fuel program for the new injectors. You
might have a fuel pressure problem; get a quality fuel pressure gauge
and install it on the schraeder valve in the fuel hard line (passenger
side front of engine block).

Could be lots of things.
 
post #5 of 7 (permalink) Old 10-24-05, 12:01 AM
Ashton Crusher
Guest
 
Posts: n/a
Re: Throttle hangs--90 LX 5.0

On Sun, 23 Oct 2005 22:46:10 GMT, "Dave Combs" <jdcombs@socal.rr.com>
wrote:

>I recently had the injectors replaced on my 5.0. Ever since then, when I
>let off the throttle coming to a stop (5-speed) the engine "hangs" at 2,000
>rpm instead of dropping to 700 rpm. Do you think they may have screwed up
>the throttle linkage or is there another likely suspect.
>
>Thanks
>


In addition to the other suggestions it could be that your Idle Air
Valve is on it's last legs. You can try cleaning it - that's hit and
miss. It's easy to replace if you don't mind parting with around $60.
 
post #6 of 7 (permalink) Old 10-25-05, 02:02 AM
Rod Williams
Guest
 
Posts: n/a
Re: Throttle hangs--90 LX 5.0

Dave Combs wrote:
> I recently had the injectors replaced on my 5.0. Ever since then, when I
> let off the throttle coming to a stop (5-speed) the engine "hangs" at 2,000
> rpm instead of dropping to 700 rpm. Do you think they may have screwed up
> the throttle linkage or is there another likely suspect.
>
> Thanks
>
>

I have an '87 that does the exact same thing. If I shut it off and
restart it everything is fine. It doesn't happen all the time and only
after I run it for a few miles. If you find the answer please let me know.
 
post #7 of 7 (permalink) Old 10-25-05, 06:01 AM
Backyard Mechanic
Guest
 
Posts: n/a
Re: Throttle hangs--90 LX 5.0

Two things, if there's no CEL on:

Idle speed control
and/or
throttle position sensor

Also the harness grounds near the PCM are sometimes flaky.. pass side kick
panel.

Actually anytime your car reaches the ten yo mark, you should take a nice
afternnon and go over the entire wairing assembly, making sure all
connections are intact and grounding points solid.


"Rod Williams" <rodw@adelphia.net> wrote in message
news:TYd7f.6673$U2.3629@trndny04...
> Dave Combs wrote:
> > I recently had the injectors replaced on my 5.0. Ever since then, when

I
> > let off the throttle coming to a stop (5-speed) the engine "hangs" at

2,000
> > rpm instead of dropping to 700 rpm. Do you think they may have screwed

up
> > the throttle linkage or is there another likely suspect.
> >
> > Thanks
> >
> >

> I have an '87 that does the exact same thing. If I shut it off and
> restart it everything is fine. It doesn't happen all the time and only
> after I run it for a few miles. If you find the answer please let me know.



 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.mustang


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome