Won't start.. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.mustang
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-09-2005, 11:02   #1 (permalink)
Ravnos
Guest
 
Posts: n/a
Won't start..

Ok, I just bought a '92 5.0 Hatchback a couple months ago. I go out
Tuesday and it won't start. Makes a slight clicking noise when I turn
the key. Got power to the dash, headlights and such, it just won't
start. Today I go out and there's nothing, no power, no clicking just
dead. The Battery is almost brand new and the alternator tests good.
I'm thinking of having the alternator tested somewhere else (Autozone
did it) but wondered if anyone had another idea what might be wrong?

Thanks


Ravnos
  Reply With Quote
Sponsored Links
Advertisement
 
Old 07-09-2005, 12:03   #2 (permalink)
SVTKate
Guest
 
Posts: n/a
Re: Won't start..

Just because the battery is nearly new, doesn't mean it cannot be bad.

I would try a different battery. Clean you battery terminals, and cable ends
throughly, and be sure they are nice and snug.

Kate


"Ravnos" <Ravnos@SPAMSUCKScox.net> wrote in message
news:qa10d156j27tti405j84jdq2cv9rdfpivk@4ax.com...
: Ok, I just bought a '92 5.0 Hatchback a couple months ago. I go out
: Tuesday and it won't start. Makes a slight clicking noise when I turn
: the key. Got power to the dash, headlights and such, it just won't
: start. Today I go out and there's nothing, no power, no clicking just
: dead. The Battery is almost brand new and the alternator tests good.
: I'm thinking of having the alternator tested somewhere else (Autozone
: did it) but wondered if anyone had another idea what might be wrong?
:
: Thanks
:
:
: Ravnos


  Reply With Quote
Old 07-09-2005, 18:01   #3 (permalink)
me
Guest
 
Posts: n/a
Re: Won't start..


"Ravnos" <Ravnos@SPAMSUCKScox.net> wrote in message
news:qa10d156j27tti405j84jdq2cv9rdfpivk@4ax.com...
> Ok, I just bought a '92 5.0 Hatchback a couple months ago. I go out
> Tuesday and it won't start. Makes a slight clicking noise when I turn
> the key. Got power to the dash, headlights and such, it just won't
> start. Today I go out and there's nothing, no power, no clicking just
> dead. The Battery is almost brand new and the alternator tests good.
> I'm thinking of having the alternator tested somewhere else (Autozone
> did it) but wondered if anyone had another idea what might be wrong?
>
> Thanks
>
>
> Ravnos


Sounds to me like something is still drawing current from the battery (other
than the cpu, clock,etc.) when your Mustang isn't running.



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > rec.autos.makers.ford.mustang



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.