front suspension repair gone wrong! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.trucks.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-17-2005, 06:01   #1 (permalink)
domzanman@aol.com
Guest
 
Posts: n/a
front suspension repair gone wrong!

I have a '01 2wd F150 with a 3.5" fabtech spindle lift with fabtech
upper control arms. The passenger side lower ball joint was blown out,
very damaged, and it had worn the spindle at the joining point of the
lower ball joint. Both pieces were repaired. Before the repair I had no
major alignment problems, only a terrible squeak. Now there is a
problem!The truck looks fine when at a stand still, and even when
driving forward. The problem is when the vehicle is put into reverse
and driven. The passenger side wheel is off camber negatively (the top
is tilted in). Fabtech tells me I have to have the truck aligned, no
shit! I have not had the pickup aligned yet because I fear that there
is something else wrong thats need repairing first, and I can do that
in my garage. If anyone has any information on what could be happening
PLEASE share!!!!

  Reply With Quote
Sponsored Links
Advertisement
 
Old 07-22-2005, 03:01   #2 (permalink)
PCK
Guest
 
Posts: n/a
Re: front suspension repair gone wrong!

somewhat normal mine does it too
<domzanman@aol.com> wrote in message
news:1121590989.312945.42310@g43g2000cwa.googlegroups.com...
>I have a '01 2wd F150 with a 3.5" fabtech spindle lift with fabtech
> upper control arms. The passenger side lower ball joint was blown out,
> very damaged, and it had worn the spindle at the joining point of the
> lower ball joint. Both pieces were repaired. Before the repair I had no
> major alignment problems, only a terrible squeak. Now there is a
> problem!The truck looks fine when at a stand still, and even when
> driving forward. The problem is when the vehicle is put into reverse
> and driven. The passenger side wheel is off camber negatively (the top
> is tilted in). Fabtech tells me I have to have the truck aligned, no
> shit! I have not had the pickup aligned yet because I fear that there
> is something else wrong thats need repairing first, and I can do that
> in my garage. If anyone has any information on what could be happening
> PLEASE share!!!!
>



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.trucks.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:34.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.