"Powerstroke, 2003 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.trucks.ford
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-14-2005, 00:11   #1 (permalink)
Jim Gemmill
Guest
 
Posts: n/a
"Powerstroke, 2003

My 6.0 went goofy the other day. Normally when I pull anything or use it on
the highway it has awesome power. But after filling it was really boggy at
start up until about 20 MPH. It hardly had any power at all at low speeds.
I got mad at it and revved the engine for a few seconds and noticed black
smoke from the exhaust. Then it seemed to run better, about normal. I
wonder if it could have been bad fuel.

Anyone else experience this kind of problem? If so, do you have a solution?

--
Jim and Dinah Gemmill
o_o_o_o
/| ,[_____],
|L --O|||||||O-
()_)()_) )_)


  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Fordforums Community > USENET NewsGroups > alt.trucks.ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:37.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.