1995 Contour acceleration Problem. Help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-17-06, 10:17 AM Thread Starter
Registered User
 
Join Date: Feb 2006
Posts: 9
confused 1995 Contour acceleration Problem. Help!

I have a 1995 Contour SE 2.5. I have a problem when I start the car up it idles rough, and when I acclerate wether It is in park or in drive it sputters and hesitates. When it get up to temp the problem is not as bad. If you gradually apply the throttle it doesn't hesitate as much or at all at times. When the engine is at temp if you get on the throttle it doesn't jump off the line like it should. It is like lacking power and when it reaches a certain rpm it is like a powerband kicks in and it seems to respond more like it should. You can feel the boost in power. Almost like a turbo. Any thoughts?

kaeschli is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-17-06, 06:23 AM
Registered User
 
Join Date: Oct 2006
Posts: 3
Re: 1995 Contour acceleration Problem. Help!

a couple of things to check are the catalytic converter, plugs and fuel filter. the cat you will have to have checked at a muffler shop, but that is what it sounds like the most. i have a 98 contour ant the cat is getting clogged up and it has the same symptoms as yours.
littledm is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome