1996 Contour SE Trans problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-22-06, 09:56 AM Thread Starter
Registered User
 
Join Date: Feb 2006
Posts: 9
confused 1996 Contour SE Trans problem

I have a 1996 Contour SE with over 180,000 miles on it. The engine runs good but recently I went to drive it and when I put the car in reverse it made this loud clunk and then nothing. I put it thru all the positions on the console and nothing. I cant tell for sure but the front tires dont seem to want to turn like it is stuck in park. I know it has lots of miles and a new trans is something I am leaning toward but before I start calling junk yards for a trans does anyone have any Ideas. I am not that familiar with this type of trans I have worked on taurus transmissions but this one seems pretty complex. Can someone help?
kaeschli is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome