2000 Ford Contour Running Rough. 5 Engine Codes. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-26-12, 07:57 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 2
2000 Ford Contour Running Rough. 5 Engine Codes.

Hi everyone I am new to this forum and I hope you guys can help me out. I have a 2000 Ford Contour (v6) that just recently started acting up. In park it will idle very rough (and lower rpm than normal) and if you tap the gas pedal the rpm's will shoot up to 2000 and hold for about 6 seconds then slowly drop back down to a very rough idle. The SES came on so I used a code reader to check the codes, I got 5 of them.

p1131 and p1151(both oxygen sensor codes) OBD Trouble Code: P1151 Lack of HO2S-21 Switch, Sensor Indicates Lean
p0171 OBD-II Trouble Code: P0171 System Too Lean (Bank 1)
p0174 OBD-II Trouble Code: P0174 System Too Lean (Bank 2)
p0420 (Cat Convt.) P0420 Error Code: Catalyst System Efficiency Below Threshold (Bank 1)

It seems that the oxygen sensors are detecting a lean condition( could also be trying to over-correct for a rich condition). I checked for vacuum leaks and there are none, I also replaced the Mass airflow sensor, no luck. All of the fuses are good. Last I checked the fuel pressure, it was in spec pressure wise (36-40 lb at idle) but the needle was twitching rapidly, is that maybe a sign that the fuel pressure regulator could be the culprit? With 5 different codes there are a lot of things it could be, so I dont want to throw a bunch of unnecessary parts at it. I'm hoping you guys can give me a little guidance on what I should do next. Do you think it could be the Idle control valve? Perhaps the oxygen sensors or EGR valve? Maybe something completely different. Thanks in advance, Dustin.

dwurz is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-26-12, 08:06 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 2000 Ford Contour Running Rough. 5 Engine Codes.

I'd clean the IAC and check the fuel pressure regulator. Make sure there's no fuel in the vacuum line to it showing it leaking.

Bert
Bert is offline  
post #3 of 3 (permalink) Old 02-26-12, 08:21 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 2
Re: 2000 Ford Contour Running Rough. 5 Engine Codes.

Thanks for the quick response, I'll check on that tomorrow.
dwurz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome