95 contour running hot - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-27-2003, 09:01   #1 (permalink)
engineimporter
Guest
 
Posts: n/a
Question 95 contour running hot

hey I was just wondering why my car runs hot? I have a 95 contour GL early model w/ the 2.0 I just replaced the water pump and temp sensor and the cars temp gauge points to the "a" in "normal". is this normal:)? I just bought the car and didn't really pay attention to the gauge before the water pump started leaking. The fan doesn't turn on until it gets to the "a" but then it just stays on and the car doesn't overheat.

Thanks in advance!!!!!
  Reply With Quote
Sponsored Links
Advertisement
 
Old 08-27-2003, 09:13   #2 (permalink)
Registered User
 
Stacy94PGT's Avatar
 
Join Date: Feb 2001
Location: The Hills of North Georgia,USA
Posts: 7,859
Re: 95 contour running hot

Thremostat may not be opening all the way.
__________________
Stacy94PGT
My first car was a 67 Mustang Coupe, 2nd one was a 67 Cougar XR-7, 3rd one was a 66 Mustang Coupe. Why did I get rid of these cars for ? I know why, because I'm stupid, stupid, stupid.

My next Ford.....
Stacy94PGT is offline   Reply With Quote
Old 08-27-2003, 09:20   #3 (permalink)
engineimporter
Guest
 
Posts: n/a
thanks I'll check that out. So it's not normal for the car to run like that?
  Reply With Quote
Old 08-27-2003, 09:41   #4 (permalink)
Registered User
 
Stacy94PGT's Avatar
 
Join Date: Feb 2001
Location: The Hills of North Georgia,USA
Posts: 7,859
Re: 95 contour running hot

I would think as in most cars the needel should be between the r and m. But, if it's staying in the normal range and not at the top where it says hot. You should be ok. Hopefully someone will post who has a 2.0 Contour and say theirs does the same thing.
__________________
Stacy94PGT
My first car was a 67 Mustang Coupe, 2nd one was a 67 Cougar XR-7, 3rd one was a 66 Mustang Coupe. Why did I get rid of these cars for ? I know why, because I'm stupid, stupid, stupid.

My next Ford.....
Stacy94PGT is offline   Reply With Quote
Old 08-27-2003, 12:37   #5 (permalink)
engineimporter
Guest
 
Posts: n/a
yeah thats what I am hoping for but I am going to replace the thermostat just to be safe and rule that out. The thermostat costs $4.00...
  Reply With Quote
Old 10-01-2003, 15:21   #6 (permalink)
Macdoctor56
Guest
 
Posts: n/a
Re: 95 contour running hot

That's not the normal temp reading. It should read between R,M. How long ago did you change the water pump and does it have a plastic inpeller? I've seen them go bad after 1 week after putting it on.
  Reply With Quote
Old 10-11-2003, 21:50   #7 (permalink)
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,561
Re: 95 contour running hot

Any updates on this? Did the Stat help or fix the issues?
LunaticSVT is offline   Reply With Quote
Old 11-03-2003, 18:48   #8 (permalink)
Registered User
 
mycainsbroken's Avatar
 
Join Date: Oct 2003
Location: Fear and Loathing, PA
Age: 33
Posts: 13
Re: 95 contour running hot

In some shops if you HAD the h20 pump replaced they may have also changed the thermostat. considering there are a couple different temps. i have a 160 degree in mine and if im at a red light or stopped traffic, it will go up that high sometimes. i also have a temp guage, so its not completely bad to have the reading this high.
__________________

-98 Contour
-68 Cougar
"If you stand for nothing you will fall for anything"
mycainsbroken is offline   Reply With Quote
Old 01-27-2004, 11:11   #9 (permalink)
Registered User
 
Join Date: Jan 2004
Posts: 4
cool Re: 95 contour running hot

Quote:
Originally Posted by engineimporter
hey I was just wondering why my car runs hot? I have a 95 contour GL early model w/ the 2.0 I just replaced the water pump and temp sensor and the cars temp gauge points to the "a" in "normal". is this normal:)? I just bought the car and didn't really pay attention to the gauge before the water pump started leaking. The fan doesn't turn on until it gets to the "a" but then it just stays on and the car doesn't overheat.

Thanks in advance!!!!!
sorry about the problems your having with that Contour.. I went through similar problems with mine after blowing a waterpump caused by my thermostat,,, I changed about everything under the sun,, waterpump,, thermostats,,, even had timing checked to make sure that it wasn't running too advanced,, but in the end,, I just took the motor out and looked everything over with a fine tooth comb,, come to find out after 100,ooo or so miles I had,, the converter was partly clogged and the after changing motors,, I hollowed out the old converter,, {Not very legal by the way},, the problem clearly went away,, so best thing to do in your case would to be,, take off the exhaust and check the catalyst converter for clogging conditions,, if so either change it,, or do as I did,,,,not recommended depending on your emissions laws,,Good luck
takeum2000 is offline   Reply With Quote
Old 01-27-2004, 11:14   #10 (permalink)
Registered User
 
Join Date: Jan 2004
Posts: 4
Re: 95 contour running hot

try checking your converter,, after a 100,000 miles or so,, its recomended to have it replaced or at least checked if your having overheating problems,,,Good luck
takeum2000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I give up =/ Walgettion The Pub 11 10-10-2003 03:18
302C Running On when key turned off 9psi EB General Tech 7 05-15-2003 05:44
running rough...looks like I'm not the only one... sbcarden General Tech 1 03-08-2003 15:09
Running In Procedure tickfordboy Australian Falcons 8 02-25-2003 14:29
EF with 200k and running Mobil One XR_Strider_GuY General Tech 24 04-15-2002 17:46

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:30.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.