96 Contour Alternator Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-29-07, 08:42 PM Thread Starter
Registered User
 
Join Date: Jul 2007
Posts: 1
96 Contour Alternator Problem

I have a 96 Contour and last week, my battery light came on. I had my alternator checked and it was undercharging. Since it was still under its lifetime warranty, I got a new one and put it in. Two miles later, my battery light came on again. I took the new alternator out and had it checked; I was told that it was defective. So, I got another one and put it in. Again, my battery light came on quickly and my analyzer is indicating that it is still undercharging. Is it possibly that I am coming across this many bad alternators or is there another problem that I should investigate? Is it possible that another problem is ruining these new alternators so quickly? I would appreciate any help or thoughts, thanks!

Jacobas is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-30-07, 07:51 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 96 Contour Alternator Problem

New parts doesn't mean they are good. Most are rebuilt and the low buck auto parts stores tend to have some bad ones. If the alt is tested off the car and it shows to be bad, then they probably are. If tested on the vehicle, and it shows it is no good, you could have a bad wire or poor ground and the alt still be good.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome