97 mondeo - burning smell - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-14-07, 06:42 AM Thread Starter
Registered User
 
Join Date: Jun 2007
Posts: 1
frown 97 mondeo - burning smell

Hi - I have a 97 modeo LX which I have recently bought. It runs very smoothly and so far have had no problems with it.
I can however smell a slight smell of burning at the end of each journey which is slightly worrying.

I am aware there is an issue with burning related to the fan when it is inoperable on settings 1-3. My fan does not work apart from on 4 so I wonder if this is the cause?
Does anyone have any more info on this problem and how it can be fixed please?

many thanks
Dave
davebarber is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-14-07, 01:16 PM
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 688
Re: 97 mondeo - burning smell

Yep sounds right, you need a new heater resistor and a repair to the wiring.
Fordtech. is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome