horn problem, lock problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-07-06, 08:30 AM Thread Starter
Registered User
 
Join Date: Feb 2006
Posts: 7
horn problem, lock problem

the horn on my 95 mondeo has stopped working, when i press the steering wheel sometimes the horn works if i have recently started the car, but most times it doesnt work. Could this be a faulty relay? if so how can i test the relay to see if it is faulty. apparently the relay also controlls the hazard lights which are working fine. if i have to take off the airbag to get to the horn ring and see if anything has come loose, how dangerous is this? im worried about setting the airbag off by mistake.

The drivers side door will lock but not unlock when using the key in it. - any help there?

the engine sound a bit thumpy / rattly when moving off in first gear with the revs up - any ideas why?

thanks,

mondeo man is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome