mondeo radio problem HELP!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-25-07, 08:30 AM Thread Starter
Registered User
 
Join Date: Jul 2007
Posts: 2
mondeo radio problem HELP!!

Hi,

I have a Ford Mondeo (2001). The Radio (which came with the car) has been getting worse and worse for the past few weeks and now it wont recieve anything at all... its just 'snow' on all FM and AM channels... the ariel seems OK, what could be causing this and how do i fix it??

kj999 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-28-07, 02:57 AM
Registered User
 
Fordtech.'s Avatar
 
Join Date: Apr 2003
Location: UK
Posts: 687
Re: mondeo radio problem HELP!!

Even with no aerial attached you should still be able to pick up stations on FM, so sounds like a faulty set.
Fordtech. is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome