mondeo speedo not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-08-07, 11:56 AM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 1
mondeo speedo not working

Hi can any one tell me whats wrong with my speedo its acting intermitant some times it works then it stops and also affects the fuel gauge. Many thanks.
gazzer1999 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-16-07, 05:30 AM
fordmech
 
backlash1's Avatar
 
Join Date: Jun 2007
Location: NSW Australia
Age: 45
Posts: 315
Re: mondeo speedo not working

Hi
If there's more than one gauge that drops off intermittently I would suspect a poor ground connection. Start at the battery terminals and go from there. cheers
marc
backlash1 is offline  
post #3 of 4 (permalink) Old 10-13-07, 06:51 AM
Registered User
 
Join Date: Oct 2007
Posts: 1
Re: mondeo speedo not working

Hmm,

Found this post while searching for a solution to what appears to be exactly the same problem on my 97 Mondeo.
Speedo drops to zero, fuel low level warning lamp comes on. After a couple of seconds it sorts itself out. Seems to happen more on wet/damp days. Have chased earths up the ying yang, but it's still happening.
rigpig is offline  
post #4 of 4 (permalink) Old 10-14-07, 05:45 AM
fordmech
 
backlash1's Avatar
 
Join Date: Jun 2007
Location: NSW Australia
Age: 45
Posts: 315
Re: mondeo speedo not working

Hi rigpig
There's also a known problem with the Vehicle Speed Sensor dropping the signal intermittently, and some cases of faulty Instrument Clusters. So you can look into that if everything else is good. cheers
Marc
backlash1 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome