No hot air! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-27-07, 06:58 AM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 1
No hot air!

I have a 1996 mk 2 1.8 Ford Mondeo. My problem: no hot air from heater system. Blower works ok, but heater control dial feels odd, doesn't zero on min and max, and there is a clunking sound from large black plastic cylinder behind and below dash when dial is turned. Sounds like a damper opening and closing. This is a new problem, not a gradual deterioration. Can you help? I'm not too good at taking things apart, but don't mind trying!
kokoshka is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome