One more question - running engine temperature... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-24-2007, 15:52   #1 (permalink)
Registered User
 
BoSoxBruin's Avatar
 
Join Date: Oct 2007
Location: United States
Posts: 20
One more question - running engine temperature...

Ok, so what temperature does your Ford Contour run at? Mine runs for the most part under the "A" in "NORMAL," and that is just a letter and space away from the red line... Isn't this hot for a car to run? And if you have read my other posts you know that I have an aftermarket intake on the car, shouldn't that make it run COOLER, not HOTTER? Please just let me know if this is normal...

Also, when I bought the car there was way to much Antifreeze in it... I siphoned out about a quart or so of it to get the level below the "max" line...
__________________
Red Sox - Soon to be 2007 World Series Champions
BoSoxBruin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-15-2007, 04:28   #2 (permalink)
fordmech
 
backlash1's Avatar
 
Join Date: Jun 2007
Location: NSW Australia
Age: 43
Posts: 315
Re: One more question - running engine temperature...

Hi
Your car seems to be running a bit on the hot side but I think it's still within specs. Here's the normal working range for a Mondeo temperature gauge, which should be the same as your car. More than 115 is considered overheating. Also, it's not the amount of anti freeze/anti boil what influences the engine temp but rather the concentration, so if you want you could try adding more water into the mix and this should lower the engine temp range. cheers
Marc
Attached Images
File Type: jpg mondeo gauge.JPG (34.3 KB, 13 views)
backlash1 is offline   Reply With Quote
Old 11-15-2007, 06:20   #3 (permalink)
Registered User
 
BoSoxBruin's Avatar
 
Join Date: Oct 2007
Location: United States
Posts: 20
Re: One more question - running engine temperature...

Yea, thanks for that pic... I have since replaced the thermo, coolant sensor, and flushed and filled with Prestone 50/50... My car now drives down the road at the end of the M...

But my problem apparently actually lies in the fan... The fan does not come on until it just about reahes the red-line, altough they work fine with the A/C... People tell me the relay is gone, but that just does not make sense to me if the low speed still works with the A/C...
__________________
Red Sox - Soon to be 2007 World Series Champions
BoSoxBruin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.