Radio ??? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar Forum for discussion of the Ford Contour, Ford Mondeo, Mercury Mystique and Ford Telstar

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-05-06, 04:20 AM Thread Starter
Registered User
 
Join Date: Mar 2006
Posts: 3
Radio ???

Last summer I 'attempted' to install a radio in my '98 Contour and everything went well for a while and then disaster happened. I noticed that at times when I hit the brake there was a click that sounds like it's coming from the gearshift(it's an auto) and then the radio would go off. I could rub my foot on the bottom of the fuse box and it would come back on. Well, it has gotten worse until a few days ago it quit altogether and my interior lights and power mirrors quit to. I don't know if it's related to the radio but I didn't have these problems before the radio. I put the factory radio back in but still nothing. Any ideas what it could be?
robertd is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Contour | Ford Mondeo | Mercury Mystique | Ford Telstar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome