1989 turbo 760 loosing power up hill but runns smooth down hill orlevel - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-12-05, 08:01 AM
Dick
Guest
 
Posts: n/a
1989 turbo 760 loosing power up hill but runns smooth down hill orlevel

1989 turbo 760 loosing power up hill but runns smooth down hill or level.
Engin is nt shaking so sparkplugs are not a suspect
gears shift ok on downslope so tranny seems ok. when Turbo kicks in it
seems to immediatly drop power more, pulling bac ccelerator actually
speds it up a bit.
antifreeze is topped up, the car did not overheat.

Looks like Turbo problem.
What is your opinion on the possible causes?
Dick


 
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-12-05, 12:01 PM
Randy G.
Guest
 
Posts: n/a
Re: 1989 turbo 760 loosing power up hill but runns smooth down hill or level

Dick <tungfree@Hawaii.rr.com> wrote:

>1989 turbo 760 loosing power up hill but runns smooth down hill or level.
>Engin is nt shaking so sparkplugs are not a suspect
>gears shift ok on downslope so tranny seems ok. when Turbo kicks in it
>seems to immediatly drop power more, pulling bac ccelerator actually
>speds it up a bit.
>antifreeze is topped up, the car did not overheat.
>
>Looks like Turbo problem.
>What is your opinion on the possible causes?


I am not turbo savy, but this generally sounds like a fuel-quality
problem. The computer may be retarding the spark because the knock
sensor is sensing knock or ping. Try a tank or two of high-quality
(name brand) premium fuel.

Otherwise, you are giving it more air but it isn't getting more fuel,
so suspect an air leak between the AMM and the throttle body or a
vacuum leak somewhere.

Just guessing...

__ __
Randy & \ \/ /alerie's
\__/olvos
'90 245 Estate - '93 965 Estate
"Shelby" & "Kate"
 
post #3 of 4 (permalink) Old 10-12-05, 02:02 PM
Boris Mohar
Guest
 
Posts: n/a
Re: 1989 turbo 760 loosing power up hill but runns smooth down hill or level

On Wed, 12 Oct 2005 10:53:16 -0700, "Randy G." <frcn@DESPAMMOcncnet.com>
wrote:

>Dick <tungfree@Hawaii.rr.com> wrote:
>
>>1989 turbo 760 loosing power up hill but runns smooth down hill or level.
>>Engin is nt shaking so sparkplugs are not a suspect
>>gears shift ok on downslope so tranny seems ok. when Turbo kicks in it
>>seems to immediatly drop power more, pulling bac ccelerator actually
>>speds it up a bit.
>>antifreeze is topped up, the car did not overheat.
>>
>>Looks like Turbo problem.
>>What is your opinion on the possible causes?

>
>I am not turbo savy, but this generally sounds like a fuel-quality
>problem. The computer may be retarding the spark because the knock
>sensor is sensing knock or ping. Try a tank or two of high-quality
>(name brand) premium fuel.
>
>Otherwise, you are giving it more air but it isn't getting more fuel,
>so suspect an air leak between the AMM and the throttle body or a
>vacuum leak somewhere.
>
>Just guessing...
>
> __ __
> Randy & \ \/ /alerie's
> \__/olvos
>'90 245 Estate - '93 965 Estate
> "Shelby" & "Kate"



That is a good guess



Regards,

Boris Mohar

Got Knock? - see:
Viatrack Printed Circuit Designs (among other things) http://www.viatrack.ca

void _-void-_ in the obvious place


 
post #4 of 4 (permalink) Old 10-12-05, 09:01 PM
James Sweet
Guest
 
Posts: n/a
Re: 1989 turbo 760 loosing power up hill but runns smooth down hill or level


"Dick" <tungfree@Hawaii.rr.com> wrote in message
news:7h93f.552$QM5.48@tornado.socal.rr.com...
> 1989 turbo 760 loosing power up hill but runns smooth down hill or level.
> Engin is nt shaking so sparkplugs are not a suspect
> gears shift ok on downslope so tranny seems ok. when Turbo kicks in it
> seems to immediatly drop power more, pulling bac ccelerator actually
> speds it up a bit.
> antifreeze is topped up, the car did not overheat.
>
> Looks like Turbo problem.
> What is your opinion on the possible causes?
> Dick


You've got a boost leak somewhere, check all the air hoses, particularly the
rubber joints at the intercooler.


 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome