760 broken shifter - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-13-05, 08:02 AM
Benjamin Smith
Posts: n/a
760 broken shifter

Last night when making a K turn my car's auto tranny's shifter felt
tight going from drive into reverse . Then the shifter's button went up
high with the spring visible, and it now will not go into park and
barely goes into reverse, although it goes into Neutral and Drive
positions normally. When it is in reverse it barely gets past the
Neutral position and not into the proper reverse slot and then goes no
further. I didn't try to force it to go too much further as the effort
is very high. The shifter was normal and new shifter bushings were put
on about a year and a half ago. Right now I'm parking and starting in
neutral and using the park brakes

Does anyone know what happened and if this is an easy and inexpensive
fix? Car is 1990 760.

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome