'89 240DL: buzzing sound when turning on turnsignals? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-17-2005, 21:01   #1 (permalink)
Joe
Guest
 
Posts: n/a
'89 240DL: buzzing sound when turning on turnsignals?

When I turn on a turnsignal, I hear this buzzing sound and the lights don't
blink. But when I turn the emergency blinking lights (all 4 turnsignals
blinking at the same time) they work. How come?
This used to happen before in a more inconsistent manner (sometimes the
turnsignals would work, but sometimes I'd hear the BUZZing sound). Now it's
more consistent and the turnsigals aren't working.

Thanks.


  Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2005, 12:05   #2 (permalink)
Mathy Van Nisselroy
Guest
 
Posts: n/a
Re: '89 240DL: buzzing sound when turning on turnsignals?

Howdy Joe, folks

> When I turn on a turnsignal, I hear this buzzing sound and the lights don't
> blink. But when I turn the emergency blinking lights (all 4 turnsignals
> blinking at the same time) they work. How come?
> This used to happen before in a more inconsistent manner (sometimes the
> turnsignals would work, but sometimes I'd hear the BUZZing sound). Now it's
> more consistent and the turnsigals aren't working.


Since the emergency lights are OK, I'ld suspect the "turning signal
switch" . What I mean by that is the electic stuff connected to the
turning signal lever. It probably isn't making contact somehow when you
want to do so. You'll probably get the same sound if your switch does
work, but you don't push the lever up or down far enough.

CU Mathy
  Reply With Quote
Old 06-18-2005, 15:01   #3 (permalink)
Lars Hoverfalt
Guest
 
Posts: n/a
Re: '89 240DL: buzzing sound when turning on turnsignals?


Does the car has a seat belt reminder light, and is it blinking at the
normal rate? The reminder light uses the same blink relay as the
turnsignals. The relay is an old fashioned electromechanical device (at
least in my -85 245) and, since it's function is load current dependent,
it can be worn out in such a way that it functions normally for the load
of all six lamps, but not for only three. Maybe you should try with
another relay?


--
Lars Hoverfalt
------------------------------------------------------------------------
Lars Hoverfalt's Profile: http://www.usenetcars.com/member.php?userid=1909
View this thread: http://www.usenetcars.com/showthread.php?t=389122

  Reply With Quote
Old 06-18-2005, 15:01   #4 (permalink)
Lars Hoverfalt
Guest
 
Posts: n/a
Re: '89 240DL: buzzing sound when turning on turnsignals?


Does the car has a seat belt reminder light, and is it blinking at the
normal rate? The reminder light uses the same blink relay as the
turnsignals. The relay is an old fashioned electromechanical device (at
least in my -85 245) and, since it's function is load current dependent,
it can be worn out in such a way that it functions normally for the load
of all six lamps, but not for only three. Maybe you should try with
another relay?

Lars


--
Lars Hoverfalt
------------------------------------------------------------------------
Lars Hoverfalt's Profile: http://www.usenetcars.com/member.php?userid=1909
View this thread: http://www.usenetcars.com/showthread.php?t=389122

  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:15.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.