Auto transmission fluid in my 2000 V70 SE...I think they killed my tranny.... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-25-2005, 07:04   #1 (permalink)
mfreedman@getconnected.com
Guest
 
Posts: n/a
Auto transmission fluid in my 2000 V70 SE...I think they killed my tranny....

I have a 2000 V70 SE. It is 2wd, no-turbo. It has the 5 speed auto
transmission, not the 4 speed in the XC and GLT models.

I took it in at 70k to have the tranny fluid and filter changed. The
transmission was working perfectly at the time. The repair place called
me after changing the fluid and said the transmission was "slipping". I
told them it was not doing this before. They then called back and said
that the 5 speed takes a different fluid than the 4 speed and that they
put the wrong fluid in. They ordered the right one and changed it
again. Still same issue with the slipping. They sent it over to a
transmission repair place that now tells me the transmission needs
rebuilding since 2nd and 3rd gears are shot.

So my question is, could they have busted my transmission by putting in
the wrong fluid? I did not even get the car back, so it was only test
driven when they discovered the problem, no significant miles were put
on it with the wrong fluid in it.

I don't know whether to be happy the problem showed up now and that I
was not left stranded somewhere, or to be mad at the repair place for
breaking my perfectly good transmission. I have a warranty, but it has
a deductible and other out of pocket expenses I'll be out.

Thanks....Miles

  Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2005, 16:01   #2 (permalink)
Peter K L Milnes
Guest
 
Posts: n/a
Re: Auto transmission fluid in my 2000 V70 SE...I think they killed my tranny....

Miles, as far as I know they should not have changed the fluid. It should be
fully synthetic ATF. Volvo say never change it, but the club recommendation
is to flush/change every 100,000 miles. The repair place should have been
fully aware of this so they have voided your warranty. They should be
prepared to fully re-imburse you for the damage caused and either it's
satisfactory repair or replacement.

All the best, Peter.

700/900/90 Register Keeper,
Volvo Owners Club (UK).

<mfreedman@getconnected.com> wrote in message
news:1127654349.511237.134790@f14g2000cwb.googlegroups.com...
>I have a 2000 V70 SE. It is 2wd, no-turbo. It has the 5 speed auto
> transmission, not the 4 speed in the XC and GLT models.
>
> I took it in at 70k to have the tranny fluid and filter changed. The
> transmission was working perfectly at the time. The repair place called
> me after changing the fluid and said the transmission was "slipping". I
> told them it was not doing this before. They then called back and said
> that the 5 speed takes a different fluid than the 4 speed and that they
> put the wrong fluid in. They ordered the right one and changed it
> again. Still same issue with the slipping. They sent it over to a
> transmission repair place that now tells me the transmission needs
> rebuilding since 2nd and 3rd gears are shot.
>
> So my question is, could they have busted my transmission by putting in
> the wrong fluid? I did not even get the car back, so it was only test
> driven when they discovered the problem, no significant miles were put
> on it with the wrong fluid in it.
>
> I don't know whether to be happy the problem showed up now and that I
> was not left stranded somewhere, or to be mad at the repair place for
> breaking my perfectly good transmission. I have a warranty, but it has
> a deductible and other out of pocket expenses I'll be out.
>
> Thanks....Miles
>



  Reply With Quote
Old 09-26-2005, 06:01   #3 (permalink)
Mike F
Guest
 
Posts: n/a
Re: Auto transmission fluid in my 2000 V70 SE...I think they killed mytranny....

mfreedman@getconnected.com wrote:
>
> I have a 2000 V70 SE. It is 2wd, no-turbo. It has the 5 speed auto
> transmission, not the 4 speed in the XC and GLT models.
>
> I took it in at 70k to have the tranny fluid and filter changed. The
> transmission was working perfectly at the time. The repair place called
> me after changing the fluid and said the transmission was "slipping". I
> told them it was not doing this before. They then called back and said
> that the 5 speed takes a different fluid than the 4 speed and that they
> put the wrong fluid in. They ordered the right one and changed it
> again. Still same issue with the slipping. They sent it over to a
> transmission repair place that now tells me the transmission needs
> rebuilding since 2nd and 3rd gears are shot.
>
> So my question is, could they have busted my transmission by putting in
> the wrong fluid? I did not even get the car back, so it was only test
> driven when they discovered the problem, no significant miles were put
> on it with the wrong fluid in it.
>
> I don't know whether to be happy the problem showed up now and that I
> was not left stranded somewhere, or to be mad at the repair place for
> breaking my perfectly good transmission. I have a warranty, but it has
> a deductible and other out of pocket expenses I'll be out.
>
> Thanks....Miles


That's what happens when Dexron is used in the 5 speed automatics where
the Volvo special fluid is called for. Usually a complete flush will
cure the problem. (16 litres at $16!)

--
Mike F.
Thornhill (near Toronto), Ont.

Replace tt with t (twice!) and remove parentheses to email me directly.
(But I check the newsgroup more often than this email address.)
  Reply With Quote
Old 09-26-2005, 09:01   #4 (permalink)
mfreedman@getconnected.com
Guest
 
Posts: n/a
Re: Auto transmission fluid in my 2000 V70 SE...I think they killed my tranny....

They're telling me it now needs a rebuild even after the complete flush
and filling it with the right stuff? Seems strange to me since it was
not drive any distance (only test driven) after the mistake....

Miles

  Reply With Quote
Old 09-26-2005, 19:01   #5 (permalink)
Reed
Guest
 
Posts: n/a
Re: Auto transmission fluid in my 2000 V70 SE...I think they killed mytranny....

mfreedman@getconnected.com wrote:
>
> They're telling me it now needs a rebuild even after the complete flush
> and filling it with the right stuff? Seems strange to me since it was
> not drive any distance (only test driven) after the mistake....
>
> Miles


According to a friend who is a Volvo dealer tech, the 2-3 gear
failure was caused when the folks who did your work mistakenly
removed the big hex "plug" on top of the trans thinking it was a
fill plug. It's not. It is called a "locating pin" and holds the
internal bands in place. Common mistake by non-trained people. He
says they see maybe 1 every 3-4 months. Newer cars now have a
non-standard 5-sided shape to prevent easy removal. Only fix is
rebuild/replace trans. Trans is supposed to be refilled thru
dipstick tube. Using standard ATF vs Volvo syn fluid usually only
causes rough shifting, no perm damage.

--reed
  Reply With Quote
Old 10-02-2005, 03:01   #6 (permalink)
John Robertson
Guest
 
Posts: n/a
Re: Auto transmission fluid in my 2000 V70 SE...I think they killed my tranny....

Try it your self ,I remember when I first drove cabs back in the seventies
the boss sent the tranny to the mechanic every 20000 and he would over
tighten the bands so much so they overheated and the tranny went .When I
brought my cabs later on I used to leave oil changes to much much higher
mileages and had no issues .Naturally I used a different mechanic till I
decided to do the tranny my self .A rebuild was not needed if the tranny was
used correctly till about 500000 but just one bad driver and it was hell
..The habit of putting the auto in forward gear while rolling back, and
taking off was the worst as well as reversing out a steep drive while the
engine and tranny was cold .It snapped cold parts easy .
<mfreedman@getconnected.com> wrote in message
news:1127746232.898107.80690@g43g2000cwa.googlegroups.com...
> They're telling me it now needs a rebuild even after the complete flush
> and filling it with the right stuff? Seems strange to me since it was
> not drive any distance (only test driven) after the mistake....
>
> Miles
>



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.