Break "Leaking" ? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-26-05, 02:01 PM
chunji08@gmail.com
Guest
 
Posts: n/a
Break "Leaking" ?

Hi all,
I have 96 Volvo 850 Wagon, Milage is about 87K.
Starting from 6 months ago, the ABS light is On and OFF for no reason.
After I checked the web, I realized it was a common "problem" for Volvo
850. For some people, they just ignore it. So did I.

But somehow, when I was driving my car this morning, I find something
else that worries me.
I was doing about 20-30 mph locally, and was trying to stop at a
traffice light. When I stepped on the break, I felt something going on
under the break step. The feeling is as if air is leaking from a ball,
or a ballon.
At the same time, the "ABS" light is turned on immediately. It lasted
for less than a second. After that, I tried to step on the gas, break,
gas, break... for several times, everything seems to work fine, except
the "ABS" light is on. ?


Any suggestion what might be ?



Thanks a lot,


cji



 
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-27-05, 09:01 AM
Marvin
Guest
 
Posts: n/a
Re: Break "Leaking" ?

chunji08@gmail.com wrote:
> Hi all,
> I have 96 Volvo 850 Wagon, Milage is about 87K.
> Starting from 6 months ago, the ABS light is On and OFF for no reason.
> After I checked the web, I realized it was a common "problem" for Volvo
> 850. For some people, they just ignore it. So did I.
>
> But somehow, when I was driving my car this morning, I find something
> else that worries me.
> I was doing about 20-30 mph locally, and was trying to stop at a
> traffice light. When I stepped on the break, I felt something going on
> under the break step. The feeling is as if air is leaking from a ball,
> or a ballon.
> At the same time, the "ABS" light is turned on immediately. It lasted
> for less than a second. After that, I tried to step on the gas, break,
> gas, break... for several times, everything seems to work fine, except
> the "ABS" light is on. ?
>
>
> Any suggestion what might be ?
>
>
>
> Thanks a lot,
>
>
> cji
>

Check the brake fluid level. If it is low, you probably have a leak. Another possiblity
is that air got in the brake lines somehow, and needs ot be drained.
 
post #3 of 6 (permalink) Old 10-27-05, 12:01 PM
John Horner
Guest
 
Posts: n/a
Re: Break "Leaking" ?

chunji08@gmail.com wrote:
> Hi all,
> I have 96 Volvo 850 Wagon, Milage is about 87K.
> Starting from 6 months ago, the ABS light is On and OFF for no reason.
> After I checked the web, I realized it was a common "problem" for Volvo
> 850. For some people, they just ignore it. So did I.
>
> But somehow, when I was driving my car this morning, I find something
> else that worries me.
> I was doing about 20-30 mph locally, and was trying to stop at a
> traffice light. When I stepped on the break, I felt something going on
> under the break step. The feeling is as if air is leaking from a ball,
> or a ballon.
> At the same time, the "ABS" light is turned on immediately. It lasted
> for less than a second. After that, I tried to step on the gas, break,
> gas, break... for several times, everything seems to work fine, except
> the "ABS" light is on. ?
>
>
> Any suggestion what might be ?
>
>
>
> Thanks a lot,
>
>
> cji
>


Sounds like a failed ABS module, and I would replace it with a
new/rebuilt unit for sure.

John
 
post #4 of 6 (permalink) Old 10-27-05, 12:01 PM
John Horner
Guest
 
Posts: n/a
Re: Break "Leaking" ?

chunji08@gmail.com wrote:
> Hi all,
> I have 96 Volvo 850 Wagon, Milage is about 87K.
> Starting from 6 months ago, the ABS light is On and OFF for no reason.
> After I checked the web, I realized it was a common "problem" for Volvo
> 850. For some people, they just ignore it. So did I.
>
> But somehow, when I was driving my car this morning, I find something
> else that worries me.
> I was doing about 20-30 mph locally, and was trying to stop at a
> traffice light. When I stepped on the break, I felt something going on
> under the break step. The feeling is as if air is leaking from a ball,
> or a ballon.
> At the same time, the "ABS" light is turned on immediately. It lasted
> for less than a second. After that, I tried to step on the gas, break,
> gas, break... for several times, everything seems to work fine, except
> the "ABS" light is on. ?
>
>
> Any suggestion what might be ?
>


Check out this website, lots of folks have reported good results from
his repairs:

http://home.earthlink.net/~vicrocha/...vo_V70_ABS.htm

John
 
post #5 of 6 (permalink) Old 10-27-05, 01:01 PM
chunji08@gmail.com
Guest
 
Posts: n/a
Re: Break "Leaking" ?


How can I tell if ABS works or not ?


thanks,


cji

 
post #6 of 6 (permalink) Old 10-27-05, 01:01 PM
James Sweet
Guest
 
Posts: n/a
Re: Break "Leaking" ?

chunji08@gmail.com wrote:
> How can I tell if ABS works or not ?
>
>
> thanks,
>
>
> cji
>



You could go find a wet road with lots of space, get up to 20 mph or so
and slam on the brakes, if the ABS is working you should hear a
chattering sound and the car should stop in a fairly straight line.
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome