XC 70 Wierd Throttle (NON) Response.... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-14-05, 01:01 PM
Posts: n/a
XC 70 Wierd Throttle (NON) Response....

Greetings from Sin City...
Strange thing happened yesterday. I was at a light, stopped and decided
to do something that is unusual for me, and that is that I put the
transmission in neutral and depressed the accelerator pedal. Nothing!
Tach stayed ad idle speed, about 1150 rpm. Took my foot off the
accelerator and stepped on it again, gradually all the way to the floor.
The engine just stayed at idle. Thinking that "something" had just
happened..."something" always happens with Volvos, I was prepared to put
the trans in drive and just let engine idle pull me off to the side of
the street. The light turned green, I put on the emergency flashers, put
the car in Drive, stepped on the gas and was off in a flash.
By the way, my XC is an '03. Driver's window was down and the A.C. was
off. I've tried the same thing about ten times since and It hasn't
happened again.
Very weird.
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Volvo
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome