discovery 2 HDC - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Land Rover
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-29-2005, 12:02   #1 (permalink)
Al Clarke
Guest
 
Posts: n/a
discovery 2 HDC

Hello group I was trying to use the HDC on my yr 2000 V8 Discovery, manual
gear box, and have found it to be non functioning. The on dashboard display
light comes on with the ignition for a couple of seconds and then goes out,
as it should but the HDC wont work as it should. I have the high low lever
in low and am in first gear but it wont work just 3 dings about 1/2 a second
apart when I turn off the switch. any clues or pointers please.

Al Clarke


  Reply With Quote
Sponsored Links
Advertisement
 
Old 03-29-2005, 14:02   #2 (permalink)
Dave Liquorice
Guest
 
Posts: n/a
Re: discovery 2 HDC

On Tue, 29 Mar 2005 18:34:10 GMT, Al Clarke wrote:

> I have the high low lever in low and am in first gear


And less than 31mph and clutch engaged (not pressed)?

> but it wont work just 3 dings about 1/2 a second apart when I turn
> off the switch.


What do you get when you switch it on? I *think* the three bongs on
switch off is normal.

The bongs actually annoy me, with so many systems all trying to use
using the bongs to signal many different states it's rather confusing.
I'm not a great fan of talking cars but I think a voice box would have
been a great improvement over the bongs (with the option for bongs
only of course...).

TBH it has to be a pretty steep hill for the HDC to actually do
anything when in 1st Low, by steep I mean > 1:5. At least thats what I
have found in my TD5...

--
Cheers new5pam@howhill.com
Dave. pam is missing e-mail



  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Land Rover



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:50.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.