Problems problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-25-05, 02:01 PM
Posts: n/a
Problems problems

I seem to have an intermittent ignition fault at least that what it appears
to be. Once going and twice coming back. It just sputters and putters, and
eventually refuses to pull at all with a cloud of black smoke.

On each occasion, I pulled over as soon as I could, revved it a bit and then
it seemed OK, even found myself doing 65mph on the M42 on the way when half
an hour earlier, it was hard put to do 30 mph on the dark and winding road
to Bromsgrove.

Oh well I meant to replace the distributor lead a while ago, after it let me
down before, mind you could be anything, from damp in the distributor cap,
to the coil I suppose.

Not only that but all the way home there was an annoying tinny rattle, I
look under the bonnet and behind the lower pulley some sort of flange seems
to have detached itseld. doesn't seem to make much difference to anything
apart from being in an impossible place to get at,

What is it, and how important is it. ?

Series 3 rust and holes

Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Land Rover
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome