Range Rover 3.9 V8 Vouge EFI question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-23-05, 06:02 PM
brett@popstarz.org.uk
Guest
 
Posts: n/a
Range Rover 3.9 V8 Vouge EFI question

My 1990 RR, shows as having no oil on the dip stick, when the engine is
not running. But when it is running, it shows a full, at the high mark.
The oil light only comes on at start up then goes out. There are no
signs of leaks and no pools of oil under it when left standing. So any
ideas why this is? Is it just a common Range Rover thing? My old Land
Rover 109 showed full with engine running or not, as does any other car
I have had.

Thanks



 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-23-05, 07:13 PM
Silas
Guest
 
Posts: n/a
Re: Range Rover 3.9 V8 Vouge EFI question

brett@popstarz.org.uk wrote:

> My 1990 RR, shows as having no oil on the dip stick, when the engine is
> not running. But when it is running, it shows a full, at the high mark.
> The oil light only comes on at start up then goes out. There are no
> signs of leaks and no pools of oil under it when left standing. So any
> ideas why this is? Is it just a common Range Rover thing? My old Land
> Rover 109 showed full with engine running or not, as does any other car
> I have had.
>
> Thanks
>

Oil level is measured when the engine is swithched off (not running).
My guess is that the oil level is low and needs to be topped up.

S
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Land Rover
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome