range rover fuel injection problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-26-05, 03:01 AM
barryeastham@aol.com
Guest
 
Posts: n/a
range rover fuel injection problems

I have a Range Rover TD6SE 2003.
FOUR times in the past 6 months it has failed to start, due to fuel
injection line failure.
Has any other RR owner had this problem? Mileage under 50k.



 
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-27-05, 12:02 PM
Huw
Guest
 
Posts: n/a
Re: range rover fuel injection problems

barryeastham@aol.com wrote:
> I have a Range Rover TD6SE 2003.
> FOUR times in the past 6 months it has failed to start, due to fuel
> injection line failure.
> Has any other RR owner had this problem? Mileage under 50k.


Perhaps you would like to post it to alt.autos.bmw as well as this forum
because the engine is essentially the same as fitted to many BMW models
including the X5.
I have had an X5 and now have a Range Rover with just over 20,000 miles on
it. No problems with the Range Rover but did have a few electrical problems
on the X5 which were common to early Range Rovers. None of the type that
will help you here though.
Try asking the question here as well perhaps, but search it to see if it has
been covered already first.
http://rangerovers.net/forum/index.php

Huw


 
post #3 of 3 (permalink) Old 12-27-05, 04:01 PM
Badger
Guest
 
Posts: n/a
Re: range rover fuel injection problems


"Huw" <hedydd[nospam]@tiscali.co.uk> wrote in message
news:41di78F1e8lr8U1@individual.net...
> barryeastham@aol.com wrote:
>> I have a Range Rover TD6SE 2003.
>> FOUR times in the past 6 months it has failed to start, due to fuel
>> injection line failure.
>> Has any other RR owner had this problem? Mileage under 50k.

>
> Perhaps you would like to post it to alt.autos.bmw as well as this forum
> because the engine is essentially the same as fitted to many BMW models
> including the X5.
> I have had an X5 and now have a Range Rover with just over 20,000 miles on
> it. No problems with the Range Rover but did have a few electrical
> problems on the X5 which were common to early Range Rovers. None of the
> type that will help you here though.
> Try asking the question here as well perhaps, but search it to see if it
> has been covered already first.
> http://rangerovers.net/forum/index.php


Check the fuel rail pressure sensor at the rear of the injection fuel rail
at the back of the cylinder head. A bad contact there will prevent it from
starting as the ecu see's a "Low fuel pressure" fault and won't let it start
up.
Badger.


 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Land Rover


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome