1992 Sovereign 4.0 Auto Power loss - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-21-05, 05:01 PM
jagman
Guest
 
Posts: n/a
1992 Sovereign 4.0 Auto Power loss

When i'm driving the car, at no specific speed, the car just dies. I find
that if I take my foot off the throttle for a few seconds it then clears
and it's back to full power.

Also, at motorway speeds the temperature gauge fluctuates between just
above cold and just below normal.

Any ideas?



 
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-21-05, 08:02 PM
Uncle-Fester
Guest
 
Posts: n/a
Re: 1992 Sovereign 4.0 Auto Power loss

jagman wrote:
> When i'm driving the car, at no specific speed, the car just dies. I find
> that if I take my foot off the throttle for a few seconds it then clears
> and it's back to full power.
>
> Also, at motorway speeds the temperature gauge fluctuates between just
> above cold and just below normal.
>
> Any ideas?
>

I have had that problem with a 97 Ford , I just pulled the battery lead
and reset the computer . So far so good .
 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Jaguar
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome