94 XJ wont run past idol - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Jaguar
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-21-2005, 08:01   #1 (permalink)
JagFan
Guest
 
Posts: n/a
94 XJ wont run past idol

94 XJ6
Ok this is one for the books. About 3 weeks ago the car would not start.
Checked for spark and have plenty. I checked the fuel pump and it seemed
to be working. Changed the filter and it still wouldn't start. The repair
shop said it could be the regulator. While looking at the manual I found
the relays on the firewall. I pulled one out and it was full of a greasy
green substance. I cleaned all the contacts and the car started. I had
another instance a week ago where it wouldn't start so I again cleaned the
terminals and it started. Yesterday while running to the store the car went
to idol and I had no power. I stopped the car and it would not start. I
fooled with the relays switching all the blue ones around until it started
but all I get is idol. When I try to give it gas it wants to die. The idol
is intermittent and fluxes between 700 in 1300. So bad relays or
regulator? Or something else? TIA for the help

  Reply With Quote
Sponsored Links
Advertisement
 
Old 08-22-2005, 01:01   #2 (permalink)
Blake Dodson
Guest
 
Posts: n/a
Re: 94 XJ wont run past idol

I would look at the throttle position sensor or the Mass Air Sensor.
Internet troubleshooting is very poor ya know?

Blake

  Reply With Quote
Old 08-22-2005, 13:01   #3 (permalink)
JagFan
Guest
 
Posts: n/a
Re: 94 XJ wont run past idol

It was the fuel pump. Why dont they just not run. Like in the old days :O)

  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Jaguar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:17.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.