X300 Windscreen wiper problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-06-05, 07:01 AM
Posts: n/a
X300 Windscreen wiper problem

I have a weird problem with my XJ6 windscreen wiper.

While driving, for no apparent reason, and without warning, the
windscreen wiper will turn on completely by itself and without
touching the wiper switch. There is usually no way to turn it off - it
will not stop either by trying the intermittent setting, or by
normal or high speed. The washers do not activate. The only way to stop it
is to pull the wiper fuse in the engine compartment.

Could it be a faulty wiper motor ? Or electrics ? I thought only
older Bosh-Lucas Jags had these sort of stupid electrical
gremlins :(

Sponsored Links
post #2 of 2 (permalink) Old 04-06-05, 10:01 AM
Blake Dodson
Posts: n/a
Re: X300 Windscreen wiper problem

Wierd. Unhook the switch before you replace the wiper control module.


Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > PAG Vehicle Discussion > Jaguar
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome