Car won't run on LPG - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > LPG Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-22-2004, 00:18   #1 (permalink)
Registered User
 
damo03's Avatar
 
Join Date: Sep 2003
Location: Melbourne
Age: 30
Posts: 36
Question Car won't run on LPG

I have a problem with my Xf on Gas. I have just re-installed the engine after a full reco and I cannot get it to run on gas. When I turn the ignition on it sends a shot of gas through into the carby, but after it fires up off that it won't continue running. It seems as though a solenoid is not kicking in or recognising that the engine has started and wont send gas down the line. Petrol runs like it should. Any ideas? I am 99.99% sure that I have reconnected everything as it should be!

Thanks

Damo
damo03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-22-2004, 01:06   #2 (permalink)
FE LTD
 
Join Date: May 2004
Location: Gold Coast
Posts: 4
Re: Car won't run on LPG

From my understanding (and im no gas mechanic) as a owner of a ford with gas its sounds like the wiring for the gas on the coil may be wrong. My understanding is that on turning on the ignition the gas flows for a second before switching off. It is only when the engine is running the soleniod gets power from the coil to keep the gas flowing. Otherwise, if the soleniod was powered continously when the ignition switch is on, then you would be pumping gas into an engine that wasn't firing and could be very dangerous. If you are unsure what you are doing, best get expert help. Never hurts to get advice from a variety of sources when it comes to fixing cars!
FE LTD is offline   Reply With Quote
Old 06-22-2004, 04:06   #3 (permalink)
Registered User
 
damo03's Avatar
 
Join Date: Sep 2003
Location: Melbourne
Age: 30
Posts: 36
cool Re: Car won't run on LPG

Thanks mate. I will check it in the morning. It's booked in for a lpg specialist anyway for thursday...but if i can fix it myself before then, i might save a few dollars. Any other ideas people?

Damo
damo03 is offline   Reply With Quote
Old 06-22-2004, 18:49   #4 (permalink)
Registered User
 
Join Date: Feb 2004
Location: Melbourne
Posts: 176
Re: Car won't run on LPG

Your car probably has an electric lock off valve in the engine bay, on the end of the supply line from the tank.
It may also have another lock off on the tank outlet (depends on how old the conversion is.. Before 1990 and there may only be one electric lock off, in the engine bay)

There's also a safety switch that controls power to the electric lock offs.
This safety switch supplies power for a second or two, to prime the system, when you turn the ignition on, but will only stay on if it senses ignition impulses.
On an XF the usual place to pick up tacho impulses is on the output side of the ignition coil.

It could be either the safety switch is U/S or the impulse sensor wire on it isn't connected.

The safety switch is up to about matchbox size and will be mounted somewhere in the engine bay. It may have an LED on it to show when it's supplying power to the lock off.

To check the lock off, get someone to start the car while you listen and put a finger on the lock off. You'll usually hear and feel it open when power is supplied to it.
__________________
---------------------------------
...Prove the fault first .. Guess later ...
...Member of the ATPS and the NFFS...
---------------------------------
rawlinna is offline   Reply With Quote
Old 06-22-2004, 18:51   #5 (permalink)
Registered User
 
Join Date: Feb 2004
Location: Melbourne
Posts: 176
Re: Car won't run on LPG

Don't overlook the obvious of course..
Is the gas turned on at the hand valve on the tank?
__________________
---------------------------------
...Prove the fault first .. Guess later ...
...Member of the ATPS and the NFFS...
---------------------------------
rawlinna is offline   Reply With Quote
Old 06-22-2004, 21:16   #6 (permalink)
Whats traction?
 
xdc351's Avatar
 
Join Date: Jul 2003
Location: Smokin melb's eastern suburbs
Age: 33
Posts: 2,197
Re: Car won't run on LPG

As stated above its likely the lock off under the hood. There will be a wire running to the 'Coil' point on the safety switch, it sounds like that wire has been connected to the + side of the coil. I had the exact same problem after a mechanic 'had' to replace my coil and just assumed it would be the + side. Move it over to the - side and it should run fine.
__________________
Just like a Tsunami.
xdc351 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > LPG Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:10.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.