eliclem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-20-09, 02:27 PM Thread Starter
Registered User
Join Date: Aug 2009
Posts: 1

Hi i have a merc 314 sprinter, i know this is a ford forum, but i thought id try anyway.
my lpg /petrol van runs ok on petrol , but when i change over to lpg it starts going into limp mode it doesn't cut out but can only be driven at 20 mph.
In a morning it will start fine ,if i drive home the night before on petrol for the last few miles. If i forget and come home on lpg it misfires until i get on a long run at speed.
If I set off on a journey and start on petrol , I may have to pull over several times and switch the engine off before I can finally switch over to gas and it run properly.eg start journey at Penrith and finally switch to gas at Morecombe.
I am desparate if anyone can help Id be really grateful
yours ELICLEM.

Last edited by eliclem; 08-20-09 at 03:20 PM. Reason: bad grammar
eliclem is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > LPG Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome