towing - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Edge Forum Forum dedicated to the discussion of the Ford Edge.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-20-14, 05:50 AM Thread Starter
Registered User
 
Join Date: Feb 2014
Posts: 2
towing

We are towing a 2013 Edge SEL behind our RV. Following instructions but end up with a dead battery after 3 hours instead of 6 Had battery checked just before we left home Any suggestions on why or a way to disconnect the battery all together

trtog7 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-20-14, 07:44 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,311
Bert is offline  
post #3 of 4 (permalink) Old 09-24-14, 06:47 PM
Registered User
 
Join Date: Sep 2014
Posts: 1
Re: towing

Ummm. I can't believe how many different forums have this listed. You should be idling your car in neutral when towing. Otherwise your transmission pump will not be lubricating vital bearings. You are asking for a dead transmission. It has been this way for ages. Unless it has changed, prove me wrong.
Camshaft is offline  
post #4 of 4 (permalink) Old 09-25-14, 04:28 AM
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,960
Re: towing

Quote:
Originally Posted by Camshaft View Post
Ummm. I can't believe how many different forums have this listed. You should be idling your car in neutral when towing. Otherwise your transmission pump will not be lubricating vital bearings. You are asking for a dead transmission. It has been this way for ages. Unless it has changed, prove me wrong.

This does vary by transmission. Many have gone to idling while towing, stopping every xxx hours, add on pump systems,disconnecting battery. It is something that needs serious attention by each owner for there car to try and prevent serious damage.
r-clar is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Ford Edge Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome