Code 52 Airbag light 1998 Ford Expedition. How do you fix it???? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Engine Specific Tech For all Ford Engines from Bigblocks to Clevelands.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-02-2007, 21:28   #1 (permalink)
Registered User
 
Join Date: Jul 2007
Posts: 2
Code 52 Airbag light 1998 Ford Expedition. How do you fix it????

I recently had my car detailed and when I brought it home the electrical started going haywire. I tried to trouble shoot the problem but was unable to locate anything. The next morning my car battery was dead. I had to jump start my car. Now the airbag light is blinking 5 times, then pauses and then blinks two times. I have read a lot about this code 52 problem and have tried to fix it but no luck. Can anyone help me with this. I dont want to have to take it in to the dealership.
Aframe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-07-2007, 04:42   #2 (permalink)
fordmech
 
backlash1's Avatar
 
Join Date: Jun 2007
Location: NSW Australia
Age: 43
Posts: 315
Re: Code 52 Airbag light 1998 Ford Expedition. How do you fix it????

Hi
I've seen you've posted the same message in 3 or 4 different forums and no one has replied yet. I can also see that you don't want to take it to a Ford dealer but the easiest way to know for sure is to get it scanned. Doesn't mean it has to be done by Ford...We don't get Expeditions imported down here, and I know for a fact that the same code will mean different things for different models or even different markets, but USUALLY this number is associated with low battery voltage, and it will come up when you jumpstart the car. If this is your case, try disconnecting the battery for a while and if it's not a hard fault it should clear itself. Hope this helps, cheers
marc
backlash1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Engine Specific Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.